Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Enthoo Luxe defective?

  1. #1

    Enthoo Luxe defective?

    Hello, I am a proud owner of an Enthoo Luxe. However, no LED's and power LED's don't work. When I first turned on the PC, the case fans didn't spin, so I figured I didn't power the fan hub, so then I connected the 12V Sata cable with another SATA cable, and connected it. Still didn't work. I then connected the case fans onto the motherboard fan hubs and voila, fans spin. Is my fan hub defective or something? Also, there is the LED cable and there are letters on the fan hub that say "LED 1" and such, but the distance between the cable and the pins is too far apart, which means either I got a really, really defective product, or I missed something. Also, someone for the love of god make Enthoo update their manual to a user friendly manual. The whole time I was like "WTF" as the case teaches me what the cables are, and not how to connect them, and half the manual is how to disassemble the case for modding. Thanks, if anyone could help!

  2. #2
    @P00P34
    There are 2 SATA connectors on the Enthoo Luxe. One has a short cable and is connected to the PWM hub, the other is what powers the LED strips. You need to have this SATA connector plugged into your power supply. The LED strips should turn on when the system is powered on. If you have connected this SATA connector and the LEDs remain off, then you can try holding the LED button for a few seconds as the strips may have been turned off. If this does not solve the issue with your LED lights you will need to send an email to support@phanteksusa.com for a replacement LED PCB as it may be defective.

  3. #3
    However, the fan hub was not powered when I connected the 12V sata cable. Also, the small little cable, that has LED on it, cannot read the power supply. Would you mind explaining a bit more? Also, please understand that my fans are powered by my motherboard fan headers, not my fan hub, as the fan hub won't work for some reason.

  4. #4
    @P00P34
    I think the cable you are referring to is the RGB LED connector. This is for connecting an internal LED light strips and is to be used as in output not an input.
    The fan hub only requires the 4-pin cable to be connected to the motherboard header to function. The 12V SATA connector is optional and will not power any fans if it is used without the 4-pin connector. If you had the 4-pin connector connected to the motherboard and the fans did not spin then you will need to email support@phanteksusa.com to start the RMA process.

  5. #5
    4 pin connector? Sorry, I'm not sure I know what you mean. I really don't want to do the RMA since my build's fully done and I can't exactly take everything apart, but I did specifically pay $50 extra for LED's and what was to be "a better build quality". I think I only connected the 12V Sata connector and that was it. My fans are only powered by the 4 pin connectors from the motherboard, and I don't know what you mean 4 pin cable. I don't remember seeing it, so please explain?

  6. #6
    There is a 4-pin cable that goes from the PWM hub to the motherboard. That is the cable required to power the fans.
    The LEDs are powered from a SATA connector. Not the SATA connector that is connected to the PWM hub.

  7. #7
    I don't think I connected that connector. I only connected the 12V Sata cable. Mind telling me what that does? Also, please for the love of god, make a user friendly manual.

  8. #8
    The 4-pin cable is what tells the PWM to turn the fans on and at what rate.

  9. #9
    The 4 Pin connector is the 12V sata cable? Cause if that's true, I just connected that sata cable into a sata port from the PSU, instead of into a 4 pin motherboard.

  10. #10
    Also, if the 4 pin connector is the 12v sata cable, do I connect it onto a motherboard 4 pin or? Cause you said directly into power supply, and I'm getting confused.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •