Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 33

Thread: Enthoo Luxe defective?

  1. #11
    The SATA is the SATA connector. It is connected to the PSU optionally. The 4-pin is on the opposite side of the PWM hub. This is required to be plugged into the motherboard.

  2. #12
    Oh lord. If I was to look at my fan hub with the case upright, would the cable be on the bottom, or the right? If that's the connector, I'll plug it in later. What does the 12V sata cable do again?

  3. #13
    I just opened my case, and on the box, there are five cables on the fan hub, but I only have two. One of the cables is the 12V sata cable, and the other one is connected to SYSFAN2 on the motherboard. Either I took three cables out, or I'm missing a cable. Just asking, the front fan, where is its connector? I couldn't find it, cause I can't remember plugging it in, and also, I think I already used it. I'm supposed to have 4 SYSFAN slots taken up, but I didn't count due to my laziness. I'll count tomorrow, three should be the case fans, one should be the CPU fan. That would make sense for the other two.

  4. #14
    Here is where you need to have the cables connected.
    connectors.jpg

  5. #15
    I remember that's the one that was connected to the SYSFAN2. Does that mean it's defective?

  6. #16
    If it really is defective, I'm going to cry. I do not want to take this whole thing apart again.

  7. #17
    Wait, so the 12V sata cable is for LED, and the 4 pin PWM cable is for the fan hub? Does the LED need the fan hub to work?

  8. #18
    If you had the 4-pin connector plugged into sysfan2 and the hub did not work then the hub is defective and you need a replacement. Send a request to support@phanteksusa.com and they can lead you through the RMA process. There is no need to cry as you will only need to switch out that small part.
    The LEDs and fan hub are 2 separate systems. They do not rely on each other to work.

  9. #19
    I will try again tomorrow, and if it really isn't working, hello RMA!

  10. #20
    How do I connect the LED cable again? Directly into what PSU port?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •