Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Phanteks Enthoo Luxe Front Panel LED

  1. #11
    Quote Originally Posted by piecemealcranky View Post
    3 weeks now without a single reply from support or the RMA team. A little disappointed...
    I have not received any email from Asia. PM me your email address and I will send you an email. Or you can email me directly at brian@phanteks.com

  2. #12
    Quote Originally Posted by brian@phanteks View Post
    I have not received any email from Asia. PM me your email address and I will send you an email. Or you can email me directly at brian@phanteks.com
    Oh that's odd, will get right to it then. Thanks...

  3. #13
    I'm pleased to report that the RMA department here has received my RMA request last week and they're arranging the requested part(s) today. Thanks Brian!

  4. #14
    Super Moderator
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    851
    Brian takes care of customers!
    Phanteks has very good customer support, but sometimes there is a problem getting the customer to the support people. Many of us have seen this.

    This is definitely not an intentional thing on Phanteks' part, but can be very exasperating for both customer and Phanteks.
    =i7 980X @ 3.55GHz =PH-TC14PE w/2x TY-147A fans =Crucial Ballistix 3x4GB =GA-X58A-UD5 =ENGTX580 DirectCU II =e quiet! Straight Power E10 500W =Enthoo Evolv w/2x PH-F140XP case intake fans;

  5. #15
    Me too. They said the will ship my two parts since Friday, but there is now answer since Friday of shopping
    :/

  6. #16
    Quote Originally Posted by Muehli_0507 View Post
    Me too. They said the will ship my two parts since Friday, but there is now answer since Friday of shopping
    :/
    Oh derp, I hope this isn't a trend.

    EDIT: I couldn't be more wrong, the item arrived today packed in bubble wrap foam and everything's in great order! Awesome, best customer experience I've had in a while. ^~^
    Last edited by piecemealcranky; 07-14-2015 at 02:53 AM. Reason: Update

  7. #17
    Yes. They dont answer on my E-Mail. I live in Germany and I need my spare parts.

  8. #18
    Right after this arrived the top panel's LED died on me (just a small portion though). Let's hope I can get the panel replaced too... again.

  9. #19
    Super Moderator
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    851
    Try emailing rma@phanteks.com as that is best way to get help outside of USA.
    =i7 980X @ 3.55GHz =PH-TC14PE w/2x TY-147A fans =Crucial Ballistix 3x4GB =GA-X58A-UD5 =ENGTX580 DirectCU II =e quiet! Straight Power E10 500W =Enthoo Evolv w/2x PH-F140XP case intake fans;

  10. #20
    Quote Originally Posted by doyll View Post
    Try emailing rma@phanteks.com as that is best way to get help outside of USA.
    Here's the story so far. The assistance they provided over here seems a little misleading, to be honest. The first RMA was a breeze, all they needed was the serial number and they shipped me a new panel. Now, they seem to mistrust my claims that the top LED has died and has instructed me to carry the case over to them for inspection. I've provided pictures and more pictures and detailed as much as possible and the RMA team over here has still yet to give a reply.

    My exhilaration with the quality of their service has been short-lived, I suppose. Brian, however, has been plenty helpful!

    Here's hoping they get back to me soon-ish.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •