Results 1 to 9 of 9

Thread: Strange thing happened

  1. #1

    Strange thing happened

    Hi All,
    It is sad that I had to go to the trouble to create a new email address and a new account here in order to post a question in this forum.
    I was away for a short time and early this morning I decided to log into this forum with my original login name to post a question about Phanteks case fans. I could not find the "Post New Thread" option. I found that very strange.
    Question: Why would Phanteks moderators or Administrator of this forum block my original subscriber to this forum from posting? I checked my email account and I have no emails from the administrators here stating why I was blocked.
    Is this normal on this particular forum to block a user if they are away for a month or less?

    I clicked on "Contact Us" and for hours now I didn't get a reply so I proceeded to create a new user here.

    Greatly appreciate a reply to this post

  2. #2
    Super Moderator
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    851
    Quote Originally Posted by Swiftfoot View Post
    Hi All,
    It is sad that I had to go to the trouble to create a new email address and a new account here in order to post a question in this forum.
    I was away for a short time and early this morning I decided to log into this forum with my original login name to post a question about Phanteks case fans. I could not find the "Post New Thread" option. I found that very strange.
    Question: Why would Phanteks moderators or Administrator of this forum block my original subscriber to this forum from posting? I checked my email account and I have no emails from the administrators here stating why I was blocked.
    Is this normal on this particular forum to block a user if they are away for a month or less?

    I clicked on "Contact Us" and for hours now I didn't get a reply so I proceeded to create a new user here.

    Greatly appreciate a reply to this post
    No idea without knowing more. I have no note from you or notices of any problems with forum. It could be that some of your posts had links to outside sites not related to forum and considered spam. Send me a PM with your original user name and I will try and help.
    =i7 980X @ 3.55GHz =PH-TC14PE w/2x TY-147A fans =Crucial Ballistix 3x4GB =GA-X58A-UD5 =ENGTX580 DirectCU II =e quiet! Straight Power E10 500W =Enthoo Evolv w/2x PH-F140XP case intake fans;

  3. #3
    Thanks doyll
    I will PM you now

  4. #4
    I sent you a PM. I hope you got it. Reading your reply here I am thinking the only thing I done here was not log in for a short period of time. I never posted any links that I am aware of.

    cheers

  5. #5
    Super Moderator
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    851
    Correct, nothing I find explains problem. I replied to your PM.
    =i7 980X @ 3.55GHz =PH-TC14PE w/2x TY-147A fans =Crucial Ballistix 3x4GB =GA-X58A-UD5 =ENGTX580 DirectCU II =e quiet! Straight Power E10 500W =Enthoo Evolv w/2x PH-F140XP case intake fans;

  6. #6
    ok Thanks. I will log Scramjet here now and see if it's fixed

  7. #7
    Nope it still shows at bottom of a category that I do not have permission to post. Also the "new post option is still missing at top of all categories.
    Can you fix the Scramjet account?

  8. #8
    Super Moderator
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    851
    Like I said in PM, I've forwarded the problem to techs. Maybe they can help, but there is nothing more I can do. Sorry.
    =i7 980X @ 3.55GHz =PH-TC14PE w/2x TY-147A fans =Crucial Ballistix 3x4GB =GA-X58A-UD5 =ENGTX580 DirectCU II =e quiet! Straight Power E10 500W =Enthoo Evolv w/2x PH-F140XP case intake fans;

  9. #9
    ok thanks
    Greatly appreciate your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •