Results 1 to 2 of 2

Thread: Enthoo Luxe Fan Hub

  1. #1

    Enthoo Luxe Fan Hub

    I recently setup my Enthoo Luxe case and it is awesome. I have not been able to get the fan hub to work though. I have tried plugging the connector to the SYS_FAN and POWER_FAN 4 pin connectors and neither of them worked. Every time I have tried, the 12V power adapter has been plugged in (I have even tried multiple SATA chains). I am trying to avoid using the CPU_FAN header as I'm not sure about using voltage control for a PWM fan. I would think the hub should power the fans, even at full speed, with the additional power, correct?

  2. #2
    Super Moderator
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    718
    Quote Originally Posted by Vox View Post
    I recently setup my Enthoo Luxe case and it is awesome. I have not been able to get the fan hub to work though. I have tried plugging the connector to the SYS_FAN and POWER_FAN 4 pin connectors and neither of them worked. Every time I have tried, the 12V power adapter has been plugged in (I have even tried multiple SATA chains). I am trying to avoid using the CPU_FAN header as I'm not sure about using voltage control for a PWM fan. I would think the hub should power the fans, even at full speed, with the additional power, correct?
    You have to have a PWM fan hub to control the Phanteks PWM fan hub or fans will only run at full speed .. and you have to have a fan plugged into the #1 fan header on hub, usually a white one .. or not run at all.
    =i7 980X @ 3.55GHz =PH-TC14PE w/2x TY-147A fans =Crucial Ballistix 3x4GB =GA-X58A-UD5 =ENGTX580 DirectCU II =e quiet! Straight Power E10 500W =Enthoo Evolv w/2x PH-F140XP case intake fans;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •