PDA

View Full Version : Enthoo Luxe Power LED cable missing?



Clark Kent
08-21-2014, 03:05 PM
I just got an Enthoo Luxe yesterday and I don't know if I'm blind but I can't find the power led cable. Should I be looking for something totally different from a standard Power LED cable or did my case not come with one?

If anyone has a Enthoo Luxe, can you please take a picture of the Power LED cable for me

Thanks

ssi91
08-21-2014, 03:56 PM
The Enthoo Luxe doesn't have a power LED cable. It uses the RGB LEDs so it only illuminates if they are on. I looked ages for it too, then it finally dawned on me how it worked.

Clark Kent
08-21-2014, 06:05 PM
The Enthoo Luxe doesn't have a power LED cable. It uses the RGB LEDs so it only illuminates if they are on. I looked ages for it too, then it finally dawned on me how it worked.

Thanks for the reply man, I've been worried sick about it all night. Where do I plug it in anyway?

P00P34
10-24-2014, 12:04 PM
I don't get it either. I built my PC and it came with a little cable labeled LED STRIP. I figured it was for the LED's but it can't connect to anything due to the fact it's short as crap, and as of now I just have a PC with no front USB ports (MSI's fault, they position for USB 3.0 MOBO ports so that I can't see what I'm connecting, so I use the back USB ports.) I also have no power LED, but I connected that fine, and I'm sure of it. Also, no LED's... I spent an extra $50 bucks for the aluminum and LED's, but I only got half the criteria.

jrben1
01-01-2015, 08:08 AM
Check out this Phanteks YouTube video on how to connect the LED strips.
https://www.youtube.com/watch?v=x7WPFS3oKYQ

jrben1
01-05-2015, 01:54 PM
I am assembling my computer now and ran into the same problem. The manual indicates that there is a Power LED connector (see Panel on page 11), but there is none to be found.
Thanks for the info on this thread.

plarsen
05-18-2015, 05:50 AM
This is kind of a shame since I guess theres is no way to get the powerbutton to glow if you want the strips not to.

Frank
05-18-2015, 04:17 PM
I just finished a new Luxe build myself. I was a little confused at first as well about the power LED, but as ssi91 said it is lit with the LED strips and it changes colour with them. I assume it also turns off with them if you hold the RGB button. Personally I love the LED strip lighting (part of the attraction to that case). As my PC sits on my desk and it is quite tall I can't see the top of the case when I'm sitting anyway.

I didn't have any issues connecting the front panel USB's either. My ASRock ATX M/B came with a USB 3 header at the front and USB 2 headers at the bottom, all of which were easily reached by the case cabling, which I thought would be standard for most M/B's.

The LED strips should already be connected when you get the case. All you have to do is plug in a SATA power connector from your PSU. My PSU cables (Thermaltake ToughPower DPS G 650W) were on the short side and I did have to buy a PSU cable extension kit to reach all the M/B power sockets.