Results 1 to 4 of 4

Thread: No fans working that connected to the PWM Hub (Enthoo evolv atx)

  1. #1

    No fans working that connected to the PWM Hub (Enthoo evolv atx)

    So I started my build 2 days ago and completed it today. Turned on the PC and everything connected to the PWM hub doesn't work. I then reconnected some of the fans to the motherboard and they work fine so it's obvious I am having issues with the hub. Not sure what to do next, but I am exhausted from trying to troubleshoot it for a couple hours straight.

    Hopefully someo one can help me. I bought the case a little over 1 month ago and would like to keep it if possible as it's great and I already have all my parts and watercooling installed into it.

  2. #2
    Make sure you plug it into the CPU Fan Header on the main board. Not the secondary one, or any other.

  3. #3
    Super Moderator
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    859
    Quote Originally Posted by Donkm View Post
    So I started my build 2 days ago and completed it today. Turned on the PC and everything connected to the PWM hub doesn't work. I then reconnected some of the fans to the motherboard and they work fine so it's obvious I am having issues with the hub. Not sure what to do next, but I am exhausted from trying to troubleshoot it for a couple hours straight.

    Hopefully someo one can help me. I bought the case a little over 1 month ago and would like to keep it if possible as it's great and I already have all my parts and watercooling installed into it.
    I know it's a dumb question, but did you plug the hub into PSU?
    =i7 980X @ 3.55GHz =PH-TC14PE w/2x TY-147A fans =Crucial Ballistix 3x4GB =GA-X58A-UD5 =ENGTX580 DirectCU II =e quiet! Straight Power E10 500W =Enthoo Evolv w/2x PH-F140XP case intake fans;

  4. #4
    Sounds busted. Both my Phanteks PWM Hubs work with or without the 12V SATA plugged in, though I keep it plugged as per instructions...get it replaced...it should work in any fan header.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •